Uploaded image for project: 'Kaa'
  1. Kaa
  2. KAA-230

Rename function prototypes in kaa_common_schema.h

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 0.6.0
    • Fix Version/s: 0.6.2
    • Component/s: Endpoint: C
    • Labels:
      None
    • Environment:
      c_sdk_refactoring branch

      Description

      As of 0.6.1 the function prototype types are named in non-descriptive fashion:

      typedef void (*serialize)(avro_writer_t writer, void *data);
      typedef void* (*deserialize)(avro_reader_t reader);
      typedef size_t (*get_size)(void *data);
      typedef void (*destruct)(void *data);
      

      This ticket is to change them to the following:

      typedef void (*serialize_fn)(avro_writer_t writer, void *data);
      typedef void* (*deserialize_fn)(avro_reader_t reader);
      typedef size_t (*get_size_fn)(void *data);
      typedef void (*destroy_fn)(void *data);
      

      The Avro C code generator must be updated accordingly. Also, destruct destruct; variables and struct fields must be renamed to destroy_fn destroy;.

        Attachments

          Activity

            People

            Assignee:
            dyosick Denis Kimcherenko
            Reporter:
            akokhanovskyi Andrew Kokhanovskyi [Administrator]
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration